summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuan Ramos <[email protected]>2023-02-22 11:39:08 -0700
committerJuan Ramos <[email protected]>2023-02-22 11:49:55 -0700
commit115820a6e5ff35881046a8e3920c2514c73e4a63 (patch)
tree707c6f989db155fe6be79d86eadaba5123d38787 /CMakeLists.txt
parent6c683158492d6b2d35fccab6dae784fef87eaf99 (diff)
downloadVulkan-Headers-115820a6e5ff35881046a8e3920c2514c73e4a63.tar.gz
Vulkan-Headers-115820a6e5ff35881046a8e3920c2514c73e4a63.zip
cmake: Update min to 3.15
- Removes conditional 3.15 logic - Guarantees usage of --install/--loglevel
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2dbda7e..6f671eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# ~~~
-cmake_minimum_required(VERSION 3.14...3.25)
+cmake_minimum_required(VERSION 3.15...3.25)
function(vlk_get_header_version)
set(vulkan_core_header_file "${CMAKE_CURRENT_SOURCE_DIR}/include/vulkan/vulkan_core.h")
@@ -43,9 +43,7 @@ vlk_get_header_version()
project(Vulkan-Headers LANGUAGES C VERSION ${VK_VERSION_STRING})
-if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.15")
- message(DEBUG "${PROJECT_NAME} = ${PROJECT_VERSION}")
-endif()
+message(DEBUG "${PROJECT_NAME} = ${PROJECT_VERSION}")
add_library(Vulkan-Headers INTERFACE)
target_include_directories(Vulkan-Headers INTERFACE $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>)