summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuan Ramos <[email protected]>2022-11-04 12:33:15 -0600
committerJuan Ramos <[email protected]>2022-11-07 10:54:57 -0700
commit91388ba10409c3a3bf5517de5fed7f2d989930f9 (patch)
treeaa631d25b10c083d7d8505339c6562d18c83eaf2 /CMakeLists.txt
parent52b7c620a5403241aa62c0cd3388384245a8b094 (diff)
downloadVulkan-Headers-91388ba10409c3a3bf5517de5fed7f2d989930f9.tar.gz
Vulkan-Headers-91388ba10409c3a3bf5517de5fed7f2d989930f9.zip
cmake: Get Vulkan Version
Extract the vulkan header version for CMake usage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50b5d89..92b195c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# ~~~
-# Copyright (c) 2018 Valve Corporation
-# Copyright (c) 2018 LunarG, Inc.
+# Copyright (c) 2018-2022 Valve Corporation
+# Copyright (c) 2018-2022 LunarG, Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -19,8 +19,10 @@
# This section contains pre-project() initialization, and ends with the project() command.
cmake_minimum_required(VERSION 3.10.2)
+include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/version.cmake)
-project(Vulkan-Headers LANGUAGES C)
+project(Vulkan-Headers LANGUAGES C VERSION ${VK_VERSION_STRING})
+message(STATUS "${PROJECT_NAME} = ${PROJECT_VERSION}")
# User-interface declarations ----------------------------------------------------------------------------------------------------
# This section contains variables that affect development GUIs (e.g. CMake GUI and IDEs), such as option(), folders, and variables