summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuan Ramos <[email protected]>2023-08-28 11:01:39 -0600
committerJuan Ramos <[email protected]>2023-08-28 16:16:25 -0600
commita0c76b4ef76e219483755ff61dce6b67ff79f24b (patch)
tree6d5c58eee2d8897237f5090066846302f3fd3dd1 /CMakeLists.txt
parent9085224a1b45f78deadf94f800b0ec092d1c3568 (diff)
downloadVulkan-Headers-a0c76b4ef76e219483755ff61dce6b67ff79f24b.tar.gz
Vulkan-Headers-a0c76b4ef76e219483755ff61dce6b67ff79f24b.zip
cmake: Document vlk_get_header_version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d9317f..ef7a803 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,10 @@
# ~~~
cmake_minimum_required(VERSION 3.15...3.25)
+# NOTE: Parsing the version like this is suboptimal but neccessary due to our release process:
+# https://github.com/KhronosGroup/Vulkan-Headers/pull/346
+#
+# As shown a more robust approach would be just to add basic test code to check the project version.
function(vlk_get_header_version)
set(vulkan_core_header_file "${CMAKE_CURRENT_SOURCE_DIR}/include/vulkan/vulkan_core.h")
if (NOT EXISTS ${vulkan_core_header_file})