summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Giessen <[email protected]>2024-06-18 12:57:48 -0500
committerCharles Giessen <[email protected]>2024-06-18 14:25:22 -0600
commit7dacb97fbace2f102d65aa3a49bff3cfe316b515 (patch)
treec0b5b1bf43be7a979b7ac980b240f9fb9ec0cd1b /CMakeLists.txt
parenta692a9c939e1cafbf30ecdfb561a4ff179504fa6 (diff)
downloadVulkan-Headers-7dacb97fbace2f102d65aa3a49bff3cfe316b515.tar.gz
Vulkan-Headers-7dacb97fbace2f102d65aa3a49bff3cfe316b515.zip
cmake: Remove explicit install of Vulkan-Module
Installing a C++ module in CMake isn't something which is well defined currently. Rather than add code which behaves poorly or flat out wrong, it is better to not try to install a binary module for the time being. The vulkan.cppm file is still included in the install so downstream users can still create a module from it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a5db4c..4e6d7f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,14 +88,6 @@ if (VULKAN_HEADERS_ENABLE_INSTALL)
set_target_properties(Vulkan-Headers PROPERTIES EXPORT_NAME "Headers")
install(TARGETS Vulkan-Headers EXPORT VulkanHeadersConfig INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
- if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.28" AND COMPILER_SUPPORTS_CXX_MODULES)
- install(TARGETS Vulkan-Module
- EXPORT VulkanHeadersConfig
- FILE_SET module
- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/include/vulkan"
- )
- endif()
-
install(EXPORT VulkanHeadersConfig NAMESPACE "Vulkan::" DESTINATION "share/cmake/VulkanHeaders")
set(version_config "${CMAKE_CURRENT_BINARY_DIR}/generated/VulkanHeadersConfigVersion.cmake")