summaryrefslogtreecommitdiffhomepage
path: root/tests/find_package/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/find_package/CMakeLists.txt')
-rw-r--r--tests/find_package/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/tests/find_package/CMakeLists.txt b/tests/find_package/CMakeLists.txt
deleted file mode 100644
index c1a9900..0000000
--- a/tests/find_package/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-# ~~~
-# Copyright 2022-2023 The Khronos Group Inc.
-# Copyright 2022-2023 Valve Corporation
-# Copyright 2022-2023 LunarG, Inc.
-#
-# SPDX-License-Identifier: Apache-2.0
-# ~~~
-cmake_minimum_required(VERSION 3.14.2)
-
-project(TEST_VULKAN_HEADERS_FIND_PACKAGE_SUPPORT LANGUAGES C)
-
-find_package(VulkanHeaders REQUIRED CONFIG)
-
-if (NOT TARGET Vulkan::Headers)
- message(FATAL_ERROR "Vulkan::Headers target not defined")
-endif()
-
-if (NOT DEFINED VulkanHeaders_VERSION)
- message(FATAL_ERROR "VulkanHeaders_VERSION not defined!")
-endif()
-message(STATUS "VulkanHeaders_VERSION = ${VulkanHeaders_VERSION}")
-
-add_library(foobar STATIC)
-
-target_link_libraries(foobar PRIVATE Vulkan::Headers)
-
-target_sources(foobar PRIVATE
- ../vk_icd.c
- ../vk_layer.c
-)