aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-cache/Cargo.toml
diff options
context:
space:
mode:
authorYuchen Wu <[email protected]>2024-10-11 17:06:46 -0700
committerYuchen Wu <[email protected]>2024-10-12 09:34:06 -0700
commitb939776792cfc1aff3b83d5cdee2ae5562805f7b (patch)
treeab7812cbbf4b1cd23854e15e297711068dbcf546 /pingora-cache/Cargo.toml
parent9921fe422274ced5ef14eb582d63529859fed441 (diff)
downloadpingora-b939776792cfc1aff3b83d5cdee2ae5562805f7b.tar.gz
pingora-b939776792cfc1aff3b83d5cdee2ae5562805f7b.zip
Refactor openssl code one more time before rustls integration
Co-authored-by: Harald Gutmann <[email protected]>
Diffstat (limited to 'pingora-cache/Cargo.toml')
-rw-r--r--pingora-cache/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pingora-cache/Cargo.toml b/pingora-cache/Cargo.toml
index 6ae6c12..235cd08 100644
--- a/pingora-cache/Cargo.toml
+++ b/pingora-cache/Cargo.toml
@@ -65,6 +65,7 @@ name = "lru_serde"
harness = false
[features]
-default = ["openssl"]
+default = []
openssl = ["pingora-core/openssl"]
boringssl = ["pingora-core/boringssl"]
+rustls = ["pingora-core/rustls"]