aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-openssl/Cargo.toml
diff options
context:
space:
mode:
authorYuchen Wu <[email protected]>2024-02-27 20:25:44 -0800
committerYuchen Wu <[email protected]>2024-02-27 20:25:44 -0800
commit8797329225018c4d0ab990166dd020338ae292dc (patch)
tree1e8d0bf6f3c27e987559f52319d91ff75e4da5cb /pingora-openssl/Cargo.toml
parent0bca116c1027a878469b72352e1e9e3916e85dde (diff)
downloadpingora-8797329225018c4d0ab990166dd020338ae292dc.tar.gz
pingora-8797329225018c4d0ab990166dd020338ae292dc.zip
Release Pingora version 0.1.0v0.1.0
Co-authored-by: Andrew Hauck <[email protected]> Co-authored-by: Edward Wang <[email protected]>
Diffstat (limited to 'pingora-openssl/Cargo.toml')
-rw-r--r--pingora-openssl/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/pingora-openssl/Cargo.toml b/pingora-openssl/Cargo.toml
new file mode 100644
index 0000000..19b3349
--- /dev/null
+++ b/pingora-openssl/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "pingora-openssl"
+version = "0.1.0"
+authors = ["Yuchen Wu <[email protected]>"]
+license = "Apache-2.0"
+edition = "2021"
+repository = "https://github.com/cloudflare/pingora"
+categories = ["asynchronous", "network-programming"]
+keywords = ["async", "tls", "ssl", "pingora"]
+description = """
+OpenSSL async APIs for Pingora.
+"""
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "pingora_openssl"
+path = "src/lib.rs"
+
+[dependencies]
+openssl-sys = "0.9"
+openssl = { version = "0.10", features = ["vendored"] }
+openssl-src = { version = "300", features = ["weak-crypto"] }
+tokio-openssl = { version = "0.6" }
+libc = "0.2.70"
+foreign-types = { version = "0.3"}
+
+[dev-dependencies]
+tokio-test = "0.4"
+tokio = { workspace = true, features = ["full"] }