aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-proxy/Cargo.toml
diff options
context:
space:
mode:
authorYuchen Wu <[email protected]>2024-07-26 10:23:14 -0700
committerYuchen Wu <[email protected]>2024-07-26 13:35:13 -0700
commit32303b9258fed5ce7d214515bddb2b7a0585fbe0 (patch)
tree5c51cf1f2f298c8bd212cf37a2d37b1ad73c3380 /pingora-proxy/Cargo.toml
parentff2582a64a5926c7ad0909f3c26b9da9ce578ba4 (diff)
downloadpingora-32303b9258fed5ce7d214515bddb2b7a0585fbe0.tar.gz
pingora-32303b9258fed5ce7d214515bddb2b7a0585fbe0.zip
Address Rust 1.80 clippy warnings.
Also remove the doc_async_trait cfg since it is no longer viable.
Diffstat (limited to 'pingora-proxy/Cargo.toml')
-rw-r--r--pingora-proxy/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pingora-proxy/Cargo.toml b/pingora-proxy/Cargo.toml
index 65f7f67..0a52dff 100644
--- a/pingora-proxy/Cargo.toml
+++ b/pingora-proxy/Cargo.toml
@@ -55,3 +55,10 @@ serde_yaml = "0.8"
default = ["openssl"]
openssl = ["pingora-core/openssl", "pingora-cache/openssl"]
boringssl = ["pingora-core/boringssl", "pingora-cache/boringssl"]
+
+# or locally cargo doc --config "build.rustdocflags='--cfg doc_async_trait'"
+[package.metadata.docs.rs]
+rustdoc-args = ["--cfg", "doc_async_trait"]
+
+[lints.rust]
+unexpected_cfgs = { level = "warn", check-cfg = ['cfg(doc_async_trait)'] } \ No newline at end of file