aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-rustls/Cargo.toml
diff options
context:
space:
mode:
authorYuchen Wu <[email protected]>2024-10-11 17:06:46 -0700
committerYuchen Wu <[email protected]>2024-10-12 09:34:06 -0700
commitb939776792cfc1aff3b83d5cdee2ae5562805f7b (patch)
treeab7812cbbf4b1cd23854e15e297711068dbcf546 /pingora-rustls/Cargo.toml
parent9921fe422274ced5ef14eb582d63529859fed441 (diff)
downloadpingora-b939776792cfc1aff3b83d5cdee2ae5562805f7b.tar.gz
pingora-b939776792cfc1aff3b83d5cdee2ae5562805f7b.zip
Refactor openssl code one more time before rustls integration
Co-authored-by: Harald Gutmann <[email protected]>
Diffstat (limited to 'pingora-rustls/Cargo.toml')
-rw-r--r--pingora-rustls/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/pingora-rustls/Cargo.toml b/pingora-rustls/Cargo.toml
new file mode 100644
index 0000000..858ce30
--- /dev/null
+++ b/pingora-rustls/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "pingora-rustls"
+version = "0.3.0"
+authors = ["Harald Gutmann <[email protected]>"]
+license = "Apache-2.0"
+edition = "2021"
+repository = "https://github.com/cloudflare/pingora"
+categories = ["asynchronous", "network-programming"]
+keywords = ["async", "tls", "ssl", "pingora"]
+description = """
+RusTLS async APIs for Pingora.
+"""
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "pingora_rustls"
+path = "src/lib.rs"