aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-limits/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pingora-limits/Cargo.toml')
-rw-r--r--pingora-limits/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/pingora-limits/Cargo.toml b/pingora-limits/Cargo.toml
new file mode 100644
index 0000000..88ee11d
--- /dev/null
+++ b/pingora-limits/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "pingora-limits"
+version = "0.1.0"
+authors = ["Yuchen Wu <[email protected]>"]
+license = "Apache-2.0"
+description = "A library for rate limiting and event frequency estimation"
+edition = "2018"
+
+[lib]
+name = "pingora_limits"
+path = "src/lib.rs"
+
+[dependencies]
+ahash = "0"
+
+[dev-dependencies]
+rand = "0"
+dashmap = "5"
+dhat = "0"
+
+[[bench]]
+name = "benchmark"
+harness = false
+
+[features]
+dhat-heap = [] # for benchmark only