aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-memory-cache/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pingora-memory-cache/Cargo.toml')
-rw-r--r--pingora-memory-cache/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pingora-memory-cache/Cargo.toml b/pingora-memory-cache/Cargo.toml
new file mode 100644
index 0000000..d51268b
--- /dev/null
+++ b/pingora-memory-cache/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "pingora-memory-cache"
+version = "0.1.0"
+authors = ["Yuchen Wu <[email protected]>"]
+license = "Apache-2.0"
+edition = "2021"
+repository = "https://github.com/cloudflare/pingora"
+categories = ["algorithms", "caching"]
+keywords = ["async", "cache", "pingora"]
+description = """
+An async in-memory cache with cache stampede protection.
+"""
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "pingora_memory_cache"
+path = "src/lib.rs"
+
+[dependencies]
+TinyUFO = { version = "0.1.0", path = "../tinyufo" }
+ahash = { workspace = true }
+tokio = { workspace = true, features = ["sync"] }
+async-trait = { workspace = true }
+pingora-error = { version = "0.1.0", path = "../pingora-error" }
+log = { workspace = true }
+parking_lot = "0"
+pingora-timeout = { version = "0.1.0", path = "../pingora-timeout" }