aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2022-03-20 18:51:24 +0100
committerBlackDex <[email protected]>2022-03-20 18:51:24 +0100
commitb0faaf25277fbbd2aea85b9c38868eb66ab45cc8 (patch)
treece71870fe49a94aea2e7f6bdbb7684e844cd3df6 /Cargo.toml
parent8d06d9c1111d642d0c2d03c1d29b0170e79f0c11 (diff)
downloadvaultwarden-b0faaf25277fbbd2aea85b9c38868eb66ab45cc8.tar.gz
vaultwarden-b0faaf25277fbbd2aea85b9c38868eb66ab45cc8.zip
Several updates and fixes
- Removed all `thread::sleep` and use `tokio::time::sleep` now. This solves an issue with updating to Bullseye ( Resolves #1998 ) - Updated all Debian images to Bullseye - Added MiMalloc feature and enabled it by default for Alpine based images This increases performance for the Alpine images because the default memory allocator for MUSL based binaries isn't that fast - Updated `dotenv` to `dotenvy` a maintained and updated fork - Fixed an issue with a newer jslib (not fully released yet) That version uses a different endpoint for `prelogin` Resolves #2378 )
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 9 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 98563c73..45057c63 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,6 +21,9 @@ postgresql = ["diesel/postgres", "diesel_migrations/postgres"]
sqlite = ["diesel/sqlite", "diesel_migrations/sqlite", "libsqlite3-sys"]
# Enable to use a vendored and statically linked openssl
vendored_openssl = ["openssl/vendored"]
+# Enable MiMalloc memory allocator to replace the default malloc
+# This can improve performance for Alpine builds
+enable_mimalloc = ["mimalloc"]
# Enable unstable features, requires nightly
# Currently only used to enable rusts official ip support
@@ -38,7 +41,7 @@ tracing = { version = "0.1.32", features = ["log"] } # Needed to have lettre and
backtrace = "0.3.64" # Logging panics to logfile instead stderr only
# A `dotenv` implementation for Rust
-dotenv = { version = "0.15.0", default-features = false }
+dotenvy = { version = "0.15.1", default-features = false }
# Lazy initialization
once_cell = "1.10.0"
@@ -113,7 +116,7 @@ percent-encoding = "2.1.0" # URL encoding library used for URL's in the emails
handlebars = { version = "4.2.2", features = ["dir_source"] }
# HTTP client
-reqwest = { version = "0.11.9", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
+reqwest = { version = "0.11.10", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
# For favicon extraction from main website
html5gum = "0.4.0"
@@ -139,6 +142,10 @@ governor = "0.4.2"
# Capture CTRL+C
ctrlc = { version = "3.2.1", features = ["termination"] }
+# Allow overriding the default memory allocator
+# Mainly used for the musl builds, since the default musl malloc is very slow
+mimalloc = { version = "0.1.28", features = ["secure"], default-features = false, optional = true }
+
[patch.crates-io]
rocket = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'ae0ccf43f11be5c00bb9cd49996c8bb06a7e1651' }