aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel García <[email protected]>2022-07-06 23:57:37 +0200
committerDaniel García <[email protected]>2022-07-06 23:57:37 +0200
commitb64cf27038f04368af8f25aa80782d37471e6303 (patch)
tree76bca867885cb583d10a55ae29f93260bdee7a9c /Cargo.toml
parent0c4e79cff6d340f1e8801ec804349250b9091035 (diff)
downloadvaultwarden-b64cf27038f04368af8f25aa80782d37471e6303.tar.gz
vaultwarden-b64cf27038f04368af8f25aa80782d37471e6303.zip
Upgrade dependencies and swap lettre to async transport
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 19db42b2..69cd7416 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,7 +45,7 @@ backtrace = "0.3.65" # Logging panics to logfile instead stderr only
dotenvy = { version = "0.15.1", default-features = false }
# Lazy initialization
-once_cell = "1.12.0"
+once_cell = "1.13.0"
# Numerical libraries
num-traits = "0.2.15"
@@ -64,8 +64,8 @@ futures = "0.3.21"
tokio = { version = "1.19.2", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.137", features = ["derive"] }
-serde_json = "1.0.81"
+serde = { version = "1.0.138", features = ["derive"] }
+serde_json = "1.0.82"
# A safe, extensible ORM and Query builder
diesel = { version = "1.4.8", features = ["chrono", "r2d2"] }
@@ -108,7 +108,7 @@ webauthn-rs = "0.3.2"
url = "2.2.2"
# Email librariese-Base, Update crates and small change.
-lettre = { version = "0.10.0-rc.7", features = ["smtp-transport", "builder", "serde", "native-tls", "hostname", "tracing"], default-features = false }
+lettre = { version = "0.10.0", features = ["smtp-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
percent-encoding = "2.1.0" # URL encoding library used for URL's in the emails
# Template library
@@ -119,10 +119,10 @@ reqwest = { version = "0.11.11", features = ["stream", "json", "gzip", "brotli",
# For favicon extraction from main website
html5gum = "0.5.2"
-regex = { version = "1.5.6", features = ["std", "perf", "unicode-perl"], default-features = false }
+regex = { version = "1.6.0", features = ["std", "perf", "unicode-perl"], default-features = false }
data-url = "0.1.1"
bytes = "1.1.0"
-cached = "0.34.1"
+cached = "0.36.0"
# Used for custom short lived cookie jar during favicon extraction
cookie = "0.16.0"