aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2021-11-28 13:02:27 +0100
committerBlackDex <[email protected]>2021-12-01 19:01:55 +0100
commite327583aa56a5129999d6295ff8a2be1ffa6d2a1 (patch)
tree9d832a731965e883259752cb20f9b5a1d702bc24 /Cargo.toml
parentead2f02cbd8a6fe29da0d0b09e68569920d3a4d2 (diff)
downloadvaultwarden-e327583aa56a5129999d6295ff8a2be1ffa6d2a1.tar.gz
vaultwarden-e327583aa56a5129999d6295ff8a2be1ffa6d2a1.zip
Enabled trust-dns and some updates.
- Enabled trust-dns feature which seems to help a bit when DNS is causing long timeouts. Though in the blocking version it is less visible then on the async branch. - Updated crates - Removed some redundant code - Updated javascript/css libraries Resolves #2118 Resolves #2119
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 6 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 87b7f871..5d4617ce 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,11 +34,11 @@ rocket = { version = "=0.5.0-dev", features = ["tls"], default-features = false
rocket_contrib = "=0.5.0-dev"
# HTTP client
-reqwest = { version = "0.11.6", features = ["blocking", "json", "gzip", "brotli", "socks", "cookies"] }
+reqwest = { version = "0.11.7", features = ["blocking", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
# Used for custom short lived cookie jar
cookie = "0.15.1"
-cookie_store = "0.15.0"
+cookie_store = "0.15.1"
bytes = "1.1.0"
url = "2.2.2"
@@ -56,7 +56,7 @@ chashmap = "2.2.2"
# A generic serialization/deserialization framework
serde = { version = "1.0.130", features = ["derive"] }
-serde_json = "1.0.68"
+serde_json = "1.0.72"
# Logging
log = "0.4.14"
@@ -115,13 +115,13 @@ tracing = { version = "0.1.29", features = ["log"] } # Needed to have lettre tra
lettre = { version = "0.10.0-rc.4", features = ["smtp-transport", "builder", "serde", "native-tls", "hostname", "tracing"], default-features = false }
# Template library
-handlebars = { version = "4.1.3", features = ["dir_source"] }
+handlebars = { version = "4.1.5", features = ["dir_source"] }
# For favicon extraction from main website
html5ever = "0.25.1"
markup5ever_rcdom = "0.1.0"
regex = { version = "1.5.4", features = ["std", "perf", "unicode-perl"], default-features = false }
-data-url = "0.1.0"
+data-url = "0.1.1"
# Used by U2F, JWT and Postgres
openssl = "0.10.38"
@@ -138,16 +138,13 @@ pico-args = "0.4.2"
backtrace = "0.3.63"
# Macro ident concatenation
-paste = "1.0.5"
+paste = "1.0.6"
[patch.crates-io]
# Use newest ring
rocket = { git = 'https://github.com/SergioBenitez/Rocket', rev = '263e39b5b429de1913ce7e3036575a7b4d88b6d7' }
rocket_contrib = { git = 'https://github.com/SergioBenitez/Rocket', rev = '263e39b5b429de1913ce7e3036575a7b4d88b6d7' }
-# For favicon extraction from main website
-data-url = { git = 'https://github.com/servo/rust-url', package="data-url", rev = 'eb7330b5296c0d43816d1346211b74182bb4ae37' }
-
# The maintainer of the `job_scheduler` crate doesn't seem to have responded
# to any issues or PRs for almost a year (as of April 2021). This hopefully
# temporary fork updates Cargo.toml to use more up-to-date dependencies.