summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathijs van Veluw <[email protected]>2023-12-09 23:04:33 +0100
committerGitHub <[email protected]>2023-12-09 23:04:33 +0100
commit3246251f295fd16dba21ec9d32afbbb104bd9c8e (patch)
treeb74920222f24255d492a8547d0c5667a6b13d5e3 /Cargo.toml
parent8ab200224e9ef0879ccd35080365118b08c43b02 (diff)
downloadvaultwarden-3246251f295fd16dba21ec9d32afbbb104bd9c8e.tar.gz
vaultwarden-3246251f295fd16dba21ec9d32afbbb104bd9c8e.zip
Fix the version string (#4153)
For some reason still not known, the `.git` directory was not copied into the container. I think buildkit (buildx) did this by default before, and stopped this with newer versions. This PR fixes this by also touching `build.rs` besides `src/main.rs`. This PR also updates Rust to v1.74.1 and some crates, including the latest version of Alpine 3.19. Fixes #4150
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ffb47122..8e14c40d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -48,7 +48,7 @@ tracing = { version = "0.1.40", features = ["log"] } # Needed to have lettre and
dotenvy = { version = "0.15.7", default-features = false }
# Lazy initialization
-once_cell = "1.18.0"
+once_cell = "1.19.0"
# Numerical libraries
num-traits = "0.2.17"
@@ -67,7 +67,7 @@ dashmap = "5.5.3"
# Async futures
futures = "0.3.29"
-tokio = { version = "1.34.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
+tokio = { version = "1.35.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
# A generic serialization/deserialization framework
serde = { version = "1.0.193", features = ["derive"] }