diff options
author | BlackDex <[email protected]> | 2023-05-06 19:46:55 +0200 |
---|---|---|
committer | BlackDex <[email protected]> | 2023-05-06 19:46:55 +0200 |
commit | 4a2ed553df0fc9753a0239f616d1a83a4ed816bc (patch) | |
tree | d7b7177a9c33f647f60bfc174d2fc6f670eb2402 /Cargo.toml | |
parent | 1ec049e2b5f2f1aa3b8d035e94915b131c5e9e25 (diff) | |
download | vaultwarden-4a2ed553df0fc9753a0239f616d1a83a4ed816bc.tar.gz vaultwarden-4a2ed553df0fc9753a0239f616d1a83a4ed816bc.zip |
Use Rocket `v0.5` branch to fix endpoints
There now is a `v0.5` branch which will be the final release version
when the time is there. Switched to this instead of the `master` branch
which contains other fixes and enhancements as well (for `v0.6`).
This should solve all the endpoint issue we were having.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -57,7 +57,7 @@ num-derive = "0.3.3" # Web framework rocket = { version = "0.5.0-rc.3", features = ["tls", "json"], default-features = false } # rocket_ws = { version ="0.1.0-rc.3" } -rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = "9b0564ed27f90686b333337d9f6ed76484a84b27" } +rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = "be496682c209e008215d81ca9dd396617c4f810a" } # v0.5 branch # WebSockets libraries tokio-tungstenite = "0.18.0" @@ -71,7 +71,7 @@ futures = "0.3.28" tokio = { version = "1.28.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } # A generic serialization/deserialization framework -serde = { version = "1.0.160", features = ["derive"] } +serde = { version = "1.0.162", features = ["derive"] } serde_json = "1.0.96" # A safe, extensible ORM and Query builder @@ -92,7 +92,7 @@ uuid = { version = "1.3.2", features = ["v4"] } # Date and time libraries chrono = { version = "0.4.24", features = ["clock", "serde"], default-features = false } chrono-tz = "0.8.2" -time = "0.3.20" +time = "0.3.21" # Job scheduler job_scheduler_ng = "2.0.4" @@ -164,8 +164,8 @@ argon2 = "0.5.0" rpassword = "7.2.0" [patch.crates-io] -rocket = { git = 'https://github.com/SergioBenitez/Rocket', rev = '9b0564ed27f90686b333337d9f6ed76484a84b27' } -# rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = '9b0564ed27f90686b333337d9f6ed76484a84b27' } +rocket = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'be496682c209e008215d81ca9dd396617c4f810a' } # v0.5 branch +# rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'be496682c209e008215d81ca9dd396617c4f810a' } # v0.5 branch # Strip debuginfo from the release builds # Also enable thin LTO for some optimizations |