summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2022-09-22 21:30:34 +0200
committerBlackDex <[email protected]>2022-09-25 16:44:34 +0200
commit1094f359c33c58ca139ae7d07aa2d7f68e79659c (patch)
tree86cb2769bd89438006a5b7e79a40ab5822840af2 /Cargo.toml
parent9c891baad1838eb3446a90b2d6d71ebace9b347c (diff)
downloadvaultwarden-1094f359c33c58ca139ae7d07aa2d7f68e79659c.tar.gz
vaultwarden-1094f359c33c58ca139ae7d07aa2d7f68e79659c.zip
Update libraries and Rust version
- Updated to Rust v1.64.0 - Updated all libararies - Updated multer-rs to be based upon the latest version - Updated Dockerfiles to match the Rust version
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 32838c72..583fe710 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,10 +42,10 @@ tracing = { version = "0.1.36", features = ["log"] } # Needed to have lettre and
backtrace = "0.3.66" # Logging panics to logfile instead stderr only
# A `dotenv` implementation for Rust
-dotenvy = { version = "=0.15.1", default-features = false }
+dotenvy = { version = "0.15.5", default-features = false }
# Lazy initialization
-once_cell = "1.14.0"
+once_cell = "1.15.0"
# Numerical libraries
num-traits = "0.2.15"
@@ -61,10 +61,10 @@ dashmap = "5.4.0"
# Async futures
futures = "0.3.24"
-tokio = { version = "1.21.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time"] }
+tokio = { version = "1.21.1", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.144", features = ["derive"] }
+serde = { version = "1.0.145", features = ["derive"] }
serde_json = "1.0.85"
# A safe, extensible ORM and Query builder
@@ -105,28 +105,28 @@ yubico = { version = "0.11.0", features = ["online-tokio"], default-features = f
webauthn-rs = "0.3.2"
# Handling of URL's for WebAuthn
-url = "2.2.2"
+url = "2.3.1"
# Email librariese-Base, Update crates and small change.
lettre = { version = "0.10.1", features = ["smtp-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
-percent-encoding = "2.1.0" # URL encoding library used for URL's in the emails
+percent-encoding = "2.2.0" # URL encoding library used for URL's in the emails
# Template library
-handlebars = { version = "4.3.3", features = ["dir_source"] }
+handlebars = { version = "4.3.4", features = ["dir_source"] }
# HTTP client
-reqwest = { version = "0.11.11", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
+reqwest = { version = "0.11.12", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
# For favicon extraction from main website
html5gum = "0.5.2"
regex = { version = "1.6.0", features = ["std", "perf", "unicode-perl"], default-features = false }
-data-url = "0.1.1"
+data-url = "0.2.0"
bytes = "1.2.1"
cached = "0.39.0"
# Used for custom short lived cookie jar during favicon extraction
cookie = "0.16.0"
-cookie_store = "0.16.1"
+cookie_store = "0.17.0"
# Used by U2F, JWT and Postgres
openssl = "0.10.41"
@@ -136,7 +136,7 @@ pico-args = "0.5.0"
# Macro ident concatenation
paste = "1.0.9"
-governor = "0.4.2"
+governor = "0.5.0"
# Capture CTRL+C
ctrlc = { version = "3.2.3", features = ["termination"] }
@@ -148,8 +148,8 @@ mimalloc = { version = "0.1.29", features = ["secure"], default-features = false
[patch.crates-io]
# Using a patched version of multer-rs (Used by Rocket) to fix attachment/send file uploads
# Issue: https://github.com/dani-garcia/vaultwarden/issues/2644
-# Patch: https://github.com/BlackDex/multer-rs/commit/73e83fa5eb183646cc56606e5d902acb30a45b3d
-multer = { git = "https://github.com/BlackDex/multer-rs", rev = "73e83fa5eb183646cc56606e5d902acb30a45b3d" }
+# Patch: https://github.com/BlackDex/multer-rs/commit/477d16b7fa0f361b5c2a5ba18a5b28bec6d26a8a
+multer = { git = "https://github.com/BlackDex/multer-rs", rev = "477d16b7fa0f361b5c2a5ba18a5b28bec6d26a8a" }
# Strip debuginfo from the release builds
# Also enable thin LTO for some optimizations