diff options
author | Daniel GarcĂa <[email protected]> | 2024-04-27 20:25:34 +0200 |
---|---|---|
committer | GitHub <[email protected]> | 2024-04-27 20:25:34 +0200 |
commit | 27dc67fadd3d45b9f7d8d37407cef9453b8f5802 (patch) | |
tree | 6f2b4de80e0e6bb0b89c91e315139993e589a76b /Cargo.toml | |
parent | 2ad33ec97f415edb2af054f527efed52b3b93a9e (diff) | |
download | vaultwarden-27dc67fadd3d45b9f7d8d37407cef9453b8f5802.tar.gz vaultwarden-27dc67fadd3d45b9f7d8d37407cef9453b8f5802.zip |
Implement custom DNS resolver (#3988)
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -67,7 +67,7 @@ dashmap = "5.5.3" # Async futures futures = "0.3.30" -tokio = { version = "1.37.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } +tokio = { version = "1.37.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal", "net"] } # A generic serialization/deserialization framework serde = { version = "1.0.198", features = ["derive"] } @@ -123,7 +123,8 @@ email_address = "0.2.4" handlebars = { version = "5.1.2", features = ["dir_source"] } # HTTP client (Used for favicons, version check, DUO and HIBP API) -reqwest = { version = "0.12.4", features = ["native-tls-alpn", "stream", "json", "gzip", "brotli", "socks", "cookies", "hickory-dns"] } +reqwest = { version = "0.12.4", features = ["native-tls-alpn", "stream", "json", "gzip", "brotli", "socks", "cookies"] } +hickory-resolver = "0.24.1" # Favicon extraction libraries html5gum = "0.5.7" |