diff options
author | BlackDex <[email protected]> | 2022-11-04 12:56:02 +0100 |
---|---|---|
committer | Daniel GarcĂa <[email protected]> | 2022-11-09 22:40:00 +0100 |
commit | 439ef44973205aaa7a306b35dd2040e8a6473eb0 (patch) | |
tree | 0f4eeda0eb46e7337c7ff1e80fee775d05776467 /Cargo.toml | |
parent | c9ec389b244c98d5cc57852f29130923fe9d6ce6 (diff) | |
download | vaultwarden-439ef44973205aaa7a306b35dd2040e8a6473eb0.tar.gz vaultwarden-439ef44973205aaa7a306b35dd2040e8a6473eb0.zip |
Update Rust version, deps and workflow
- Update Rust to v1.65.0
- Update dependencies
- Updated workflow files
- Added some extra clippy checks
- Fixed some clippy checks
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 16 |
1 files changed, 8 insertions, 8 deletions
@@ -45,7 +45,7 @@ backtrace = "0.3.66" # Logging panics to logfile instead stderr only dotenvy = { version = "0.15.6", default-features = false } # Lazy initialization -once_cell = "1.15.0" +once_cell = "1.16.0" # Numerical libraries num-traits = "0.2.15" @@ -72,7 +72,7 @@ diesel = { version = "2.0.2", features = ["chrono", "r2d2"] } diesel_migrations = "2.0.0" # Bundled SQLite -libsqlite3-sys = { version = "0.25.1", features = ["bundled"], optional = true } +libsqlite3-sys = { version = "0.25.2", features = ["bundled"], optional = true } # Crypto-related libraries rand = { version = "0.8.5", features = ["small_rng"] } @@ -83,8 +83,8 @@ uuid = { version = "1.2.1", features = ["v4"] } # Date and time libraries chrono = { version = "0.4.22", features = ["clock", "serde"], default-features = false } -chrono-tz = "0.7.0" -time = "0.3.16" +chrono-tz = "0.8.0" +time = "0.3.17" # Job scheduler job_scheduler_ng = "2.0.2" @@ -110,7 +110,7 @@ url = "2.3.1" # Email librariese-Base, Update crates and small change. lettre = { version = "0.10.1", features = ["smtp-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false } percent-encoding = "2.2.0" # URL encoding library used for URL's in the emails -email_address = "0.2.3" +email_address = "0.2.4" # Template library handlebars = { version = "4.3.5", features = ["dir_source"] } @@ -120,14 +120,14 @@ reqwest = { version = "0.11.12", features = ["stream", "json", "gzip", "brotli", # For favicon extraction from main website html5gum = "0.5.2" -regex = { version = "1.6.0", features = ["std", "perf", "unicode-perl"], default-features = false } +regex = { version = "1.7.0", features = ["std", "perf", "unicode-perl"], default-features = false } data-url = "0.2.0" bytes = "1.2.1" cached = "0.40.0" # Used for custom short lived cookie jar during favicon extraction cookie = "0.16.1" -cookie_store = "0.18.0" +cookie_store = "0.19.0" # Used by U2F, JWT and Postgres openssl = "0.10.42" @@ -147,7 +147,7 @@ semver = "1.0.14" # Allow overriding the default memory allocator # Mainly used for the musl builds, since the default musl malloc is very slow -mimalloc = { version = "0.1.30", features = ["secure"], default-features = false, optional = true } +mimalloc = { version = "0.1.31", features = ["secure"], default-features = false, optional = true } [patch.crates-io] # Using a patched version of multer-rs (Used by Rocket) to fix attachment/send file uploads |