summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2023-04-12 15:59:05 +0200
committerBlackDex <[email protected]>2023-04-12 15:59:05 +0200
commit48cc31a59f3b069eb5869fde7954bff38e99d764 (patch)
tree3e123f910b1201d3763d01f226134f3f9e4db4da /Cargo.toml
parent07099df41a6e4ac1c35afb636465b259b3d6073d (diff)
downloadvaultwarden-48cc31a59f3b069eb5869fde7954bff38e99d764.tar.gz
vaultwarden-48cc31a59f3b069eb5869fde7954bff38e99d764.zip
Small update to Rocket WebSockets
Switched from channels to stream. This is able to use yield, and the code looks a bit nicer this way. Also updated all the crates.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a5167a26..013a1e41 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -71,7 +71,7 @@ futures = "0.3.28"
tokio = { version = "1.27.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.159", features = ["derive"] }
+serde = { version = "1.0.160", features = ["derive"] }
serde_json = "1.0.95"
# A safe, extensible ORM and Query builder
@@ -133,7 +133,7 @@ data-url = "0.2.0"
bytes = "1.4.0"
# Cache function results (Used for version check and favicon fetching)
-cached = "0.42.0"
+cached = "0.43.0"
# Used for custom short lived cookie jar during favicon extraction
cookie = "0.16.2"