diff options
author | BlackDex <[email protected]> | 2023-04-12 15:59:05 +0200 |
---|---|---|
committer | BlackDex <[email protected]> | 2023-04-12 15:59:05 +0200 |
commit | 48cc31a59f3b069eb5869fde7954bff38e99d764 (patch) | |
tree | 3e123f910b1201d3763d01f226134f3f9e4db4da /Cargo.toml | |
parent | 07099df41a6e4ac1c35afb636465b259b3d6073d (diff) | |
download | vaultwarden-48cc31a59f3b069eb5869fde7954bff38e99d764.tar.gz vaultwarden-48cc31a59f3b069eb5869fde7954bff38e99d764.zip |
Small update to Rocket WebSockets
Switched from channels to stream. This is able to use yield, and the
code looks a bit nicer this way.
Also updated all the crates.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -71,7 +71,7 @@ futures = "0.3.28" tokio = { version = "1.27.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } # A generic serialization/deserialization framework -serde = { version = "1.0.159", features = ["derive"] } +serde = { version = "1.0.160", features = ["derive"] } serde_json = "1.0.95" # A safe, extensible ORM and Query builder @@ -133,7 +133,7 @@ data-url = "0.2.0" bytes = "1.4.0" # Cache function results (Used for version check and favicon fetching) -cached = "0.42.0" +cached = "0.43.0" # Used for custom short lived cookie jar during favicon extraction cookie = "0.16.2" |