diff options
author | BlackDex <[email protected]> | 2022-06-08 19:46:33 +0200 |
---|---|---|
committer | BlackDex <[email protected]> | 2022-06-14 14:51:51 +0200 |
commit | 5d05ec58be9e6dcb028d69a4280a1d9e9d99f20e (patch) | |
tree | a7e1f4403a922b8624fb8e42fed5ba25533115e1 /Cargo.toml | |
parent | f95bd3bb04839ea4fa8f2700cd3867ee12b260b0 (diff) | |
download | vaultwarden-5d05ec58be9e6dcb028d69a4280a1d9e9d99f20e.tar.gz vaultwarden-5d05ec58be9e6dcb028d69a4280a1d9e9d99f20e.zip |
Updated deps and misc fixes and updates
- Updated some Rust dependencies
- Fixed an issue with CSP header, this was not configured correctly
- Prevent sending CSP and Frame headers for the MFA connector.html files.
Else some clients will fail to handle these protocols.
- Add `unsafe-inline` for `script-src` only to the CSP for the Admin Interface
- Updated JavaScript and CSS files for the Admin interface
- Changed the layout for showing overridden settings, better visible now.
- Made the version check cachable to prevent hitting the Github API rate limits
- Hide the `database_url` as if it is a password in the Admin Interface
Else for MariaDB/MySQL or PostgreSQL this was plain text.
- Fixed an issue that pressing enter on the SMTP Test would save the config.
resolves #2542
- Prevent user names larger then 50 characters
resolves #2419
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -37,7 +37,7 @@ syslog = "6.0.1" # Needs to be v4 until fern is updated # Logging log = "0.4.17" fern = { version = "0.6.1", features = ["syslog-6"] } -tracing = { version = "0.1.34", features = ["log"] } # Needed to have lettre and webauthn-rs trace logging to work +tracing = { version = "0.1.35", features = ["log"] } # Needed to have lettre and webauthn-rs trace logging to work backtrace = "0.3.65" # Logging panics to logfile instead stderr only @@ -61,7 +61,7 @@ dashmap = "5.3.4" # Concurrent hashmap implementation # Async futures futures = "0.3.21" -tokio = { version = "1.19.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time"] } +tokio = { version = "1.19.2", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time"] } # A generic serialization/deserialization framework serde = { version = "1.0.137", features = ["derive"] } @@ -79,7 +79,7 @@ rand = { version = "0.8.5", features = ["small_rng"] } ring = "0.16.20" # UUID generation -uuid = { version = "1.1.1", features = ["v4"] } +uuid = { version = "1.1.2", features = ["v4"] } # Date and time libraries chrono = { version = "0.4.19", features = ["clock", "serde"], default-features = false } @@ -112,17 +112,17 @@ lettre = { version = "0.10.0-rc.7", features = ["smtp-transport", "builder", "se percent-encoding = "2.1.0" # URL encoding library used for URL's in the emails # Template library -handlebars = { version = "4.3.0", features = ["dir_source"] } +handlebars = { version = "4.3.1", features = ["dir_source"] } # HTTP client -reqwest = { version = "0.11.10", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] } +reqwest = { version = "0.11.11", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] } # For favicon extraction from main website html5gum = "0.4.0" regex = { version = "1.5.6", features = ["std", "perf", "unicode-perl"], default-features = false } data-url = "0.1.1" bytes = "1.1.0" -cached = "0.34.0" +cached = "0.34.1" # Used for custom short lived cookie jar during favicon extraction cookie = "0.16.0" |