summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathijs van Veluw <[email protected]>2024-05-19 20:30:34 +0200
committerGitHub <[email protected]>2024-05-19 20:30:34 +0200
commit6cadb2627a80a5a32a0f64adc8b810297e586aaf (patch)
treee2d7353bc17ef1638031e7293ecba688d3e3b3c4 /Cargo.toml
parent0fe93edea6cb8d4b30416a6d319164f8828ad8b7 (diff)
downloadvaultwarden-6cadb2627a80a5a32a0f64adc8b810297e586aaf.tar.gz
vaultwarden-6cadb2627a80a5a32a0f64adc8b810297e586aaf.zip
Update Rust, crates and web-vault (#4558)
* Update Rust and crates - Updated Rust to v1.78.0 - Updated crates * Update web-vault to v2024.5.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 82071435..2b90e6a6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,7 @@ name = "vaultwarden"
version = "1.0.0"
authors = ["Daniel GarcĂ­a <[email protected]>"]
edition = "2021"
-rust-version = "1.75.0"
+rust-version = "1.76.0"
resolver = "2"
repository = "https://github.com/dani-garcia/vaultwarden"
@@ -51,7 +51,7 @@ dotenvy = { version = "0.15.7", default-features = false }
once_cell = "1.19.0"
# Numerical libraries
-num-traits = "0.2.18"
+num-traits = "0.2.19"
num-derive = "0.4.2"
bigdecimal = "0.4.3"
@@ -60,7 +60,7 @@ rocket = { version = "0.5.0", features = ["tls", "json"], default-features = fal
rocket_ws = { version ="0.1.0" }
# WebSockets libraries
-rmpv = "1.0.2" # MessagePack library
+rmpv = "1.3.0" # MessagePack library
# Concurrent HashMap used for WebSocket messaging and favicons
dashmap = "5.5.3"
@@ -70,8 +70,8 @@ futures = "0.3.30"
tokio = { version = "1.37.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal", "net"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.198", features = ["derive"] }
-serde_json = "1.0.116"
+serde = { version = "1.0.202", features = ["derive"] }
+serde_json = "1.0.117"
# A safe, extensible ORM and Query builder
diesel = { version = "2.1.6", features = ["chrono", "r2d2", "numeric"] }
@@ -97,7 +97,7 @@ time = "0.3.36"
job_scheduler_ng = "2.0.5"
# Data encoding library Hex/Base32/Base64
-data-encoding = "2.5.0"
+data-encoding = "2.6.0"
# JWT library
jsonwebtoken = "9.3.0"
@@ -133,7 +133,7 @@ data-url = "0.3.1"
bytes = "1.6.0"
# Cache function results (Used for version check and favicon fetching)
-cached = { version = "0.50.0", features = ["async"] }
+cached = { version = "0.51.3", features = ["async"] }
# Used for custom short lived cookie jar during favicon extraction
cookie = "0.18.1"
@@ -146,11 +146,11 @@ openssl = "0.10.64"
pico-args = "0.5.0"
# Macro ident concatenation
-paste = "1.0.14"
+paste = "1.0.15"
governor = "0.6.3"
# Check client versions for specific features.
-semver = "1.0.22"
+semver = "1.0.23"
# Allow overriding the default memory allocator
# Mainly used for the musl builds, since the default musl malloc is very slow