summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2023-02-08 17:13:14 +0100
committerBlackDex <[email protected]>2023-02-13 08:32:01 +0100
commita0a499425024d58595ed672a901987ac523e77e1 (patch)
treec09e2b9bdb7cdfed34a3e10be644f26480593d97 /Cargo.toml
parent32dfa419700c5d9afc62c963215843ef47504197 (diff)
downloadvaultwarden-a0a499425024d58595ed672a901987ac523e77e1.tar.gz
vaultwarden-a0a499425024d58595ed672a901987ac523e77e1.zip
Updated Rust and crates
- Updated Rust to v1.67.0 - Updated all crates except for `cookies` and `webauthn`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 18 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 88a3b4b5..d93c261e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -62,22 +62,24 @@ rocket = { version = "0.5.0-rc.2", features = ["tls", "json"], default-features
# WebSockets libraries
tokio-tungstenite = "0.18.0"
rmpv = "1.0.0" # MessagePack library
+
+# Concurrent HashMap used for WebSocket messaging and favicons
dashmap = "5.4.0"
# Async futures
-futures = "0.3.25"
-tokio = { version = "1.24.2", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
+futures = "0.3.26"
+tokio = { version = "1.25.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
# A generic serialization/deserialization framework
serde = { version = "1.0.152", features = ["derive"] }
-serde_json = "1.0.91"
+serde_json = "1.0.93"
# A safe, extensible ORM and Query builder
diesel = { version = "2.0.3", features = ["chrono", "r2d2"] }
diesel_migrations = "2.0.0"
diesel_logger = { version = "0.2.0", optional = true }
-# Bundled SQLite
+# Bundled/Static SQLite
libsqlite3-sys = { version = "0.25.2", features = ["bundled"], optional = true }
# Crypto-related libraries
@@ -85,7 +87,7 @@ rand = { version = "0.8.5", features = ["small_rng"] }
ring = "0.16.20"
# UUID generation
-uuid = { version = "1.2.2", features = ["v4"] }
+uuid = { version = "1.3.0", features = ["v4"] }
# Date and time libraries
chrono = { version = "0.4.23", features = ["clock", "serde"], default-features = false }
@@ -93,7 +95,7 @@ chrono-tz = "0.8.1"
time = "0.3.17"
# Job scheduler
-job_scheduler_ng = "2.0.3"
+job_scheduler_ng = "2.0.4"
# Data encoding library Hex/Base32/Base64
data-encoding = "2.3.3"
@@ -110,32 +112,34 @@ yubico = { version = "0.11.0", features = ["online-tokio"], default-features = f
# WebAuthn libraries
webauthn-rs = "0.3.2"
-# Handling of URL's for WebAuthn
+# Handling of URL's for WebAuthn and favicons
url = "2.3.1"
-# Email librariese-Base, Update crates and small change.
-lettre = { version = "0.10.1", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
+# Email libraries
+lettre = { version = "0.10.2", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
percent-encoding = "2.2.0" # URL encoding library used for URL's in the emails
email_address = "0.2.4"
-# Template library
+# HTML Template library
handlebars = { version = "4.3.6", features = ["dir_source"] }
-# HTTP client
+# HTTP client (Used for favicons, version check, DUO and HIBP API)
reqwest = { version = "0.11.14", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
-# For favicon extraction from main website
+# Favicon extraction libraries
html5gum = "0.5.2"
regex = { version = "1.7.1", features = ["std", "perf", "unicode-perl"], default-features = false }
data-url = "0.2.0"
-bytes = "1.3.0"
+bytes = "1.4.0"
+
+# Cache function results (Used for version check and favicon fetching)
cached = "0.42.0"
# Used for custom short lived cookie jar during favicon extraction
cookie = "0.16.2"
cookie_store = "0.19.0"
-# Used by U2F, JWT and Postgres
+# Used by U2F, JWT and PostgreSQL
openssl = "0.10.45"
# CLI argument parsing