diff options
author | BlackDex <[email protected]> | 2022-06-21 18:47:01 +0200 |
---|---|---|
committer | BlackDex <[email protected]> | 2022-06-25 11:29:08 +0200 |
commit | c7a752b01d704c116d715d75f75ff6fa00ab964d (patch) | |
tree | f7fde75ad87286b368aa0fb1ad9e5d294e0570ea /Cargo.toml | |
parent | 887e320e7f8dfc62d9b3ed08aca216cd7ad229f1 (diff) | |
download | vaultwarden-c7a752b01d704c116d715d75f75ff6fa00ab964d.tar.gz vaultwarden-c7a752b01d704c116d715d75f75ff6fa00ab964d.zip |
Update dep's and small improvements on favicons
- Updated dependencies (html5gum for favicon downloading)
* Also openssl, time, jsonwebtoken and r2d2
- Small optimizations on downloading favicons.
It now only emits tokens/tags which needs to be parsed, all others are
being skipped. This prevents unneeded items within the for-loop being
parsed.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -84,7 +84,7 @@ uuid = { version = "1.1.2", features = ["v4"] } # Date and time libraries chrono = { version = "0.4.19", features = ["clock", "serde"], default-features = false } chrono-tz = "0.6.1" -time = "0.3.9" +time = "0.3.11" # Job scheduler job_scheduler_ng = "2.0.1" @@ -93,7 +93,7 @@ job_scheduler_ng = "2.0.1" data-encoding = "2.3.2" # JWT library -jsonwebtoken = "8.1.0" +jsonwebtoken = "8.1.1" # TOTP library totp-lite = "2.0.0" @@ -118,7 +118,7 @@ handlebars = { version = "4.3.1", features = ["dir_source"] } reqwest = { version = "0.11.11", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] } # For favicon extraction from main website -html5gum = "0.4.0" +html5gum = "0.5.2" regex = { version = "1.5.6", features = ["std", "perf", "unicode-perl"], default-features = false } data-url = "0.1.1" bytes = "1.1.0" |