diff options
author | Daniel García <[email protected]> | 2018-12-06 20:35:25 +0100 |
---|---|---|
committer | Daniel García <[email protected]> | 2018-12-06 20:35:25 +0100 |
commit | 2fde4e693363266a93d450f26ad0b5cc9cebb53a (patch) | |
tree | f4a4ba9cb922e08057f412a9c152ef369ed07a79 /Cargo.toml | |
parent | 259a2f2982dcc49dd095e8bce368824d2886fd30 (diff) | |
download | vaultwarden-2fde4e693363266a93d450f26ad0b5cc9cebb53a.tar.gz vaultwarden-2fde4e693363266a93d450f26ad0b5cc9cebb53a.zip |
Implemented proper logging, with support for file logging, timestamp and syslog (this last one is untested)
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -3,6 +3,9 @@ name = "bitwarden_rs" version = "1.0.0" authors = ["Daniel García <[email protected]>"] +[features] +enable_syslog = ["syslog", "fern/syslog-4"] + [dependencies] # Web framework for nightly with a focus on ease-of-use, expressibility, and speed. rocket = { version = "0.4.0", features = ["tls"], default-features = false } @@ -28,6 +31,11 @@ serde = "1.0.80" serde_derive = "1.0.80" serde_json = "1.0.33" +# Logging +log = "0.4.6" +fern = "0.5.7" +syslog = { version = "4.0.1", optional = true } + # A safe, extensible ORM and Query builder diesel = { version = "1.3.3", features = ["sqlite", "chrono", "r2d2"] } diesel_migrations = { version = "1.3.0", features = ["sqlite"] } |