aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorStepan Fedorko-Bartos <[email protected]>2018-11-16 11:28:20 -0700
committerStepan Fedorko-Bartos <[email protected]>2018-11-16 11:28:20 -0700
commit5a8d5e426dca0f5c3d03db0722ddc1457e7c7ceb (patch)
tree86a59a20dfa45a5d5f341a7f124eb6986311b3a6 /Cargo.toml
parent2c233cda8bd123f9156fc3ba3f6800fd1fa3e4c3 (diff)
downloadvaultwarden-5a8d5e426dca0f5c3d03db0722ddc1457e7c7ceb.tar.gz
vaultwarden-5a8d5e426dca0f5c3d03db0722ddc1457e7c7ceb.zip
Switches to Downstream yubico with Optional libusb
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e993dc43..60b60e54 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -58,7 +58,7 @@ jsonwebtoken = "= 4.0.1"
u2f = "0.1.2"
# Yubico Library
-yubico="0.4.0"
+yubico= { version = "0.4.0", default-features = false }
# A `dotenv` implementation for Rust
dotenv = { version = "0.13.0", default-features = false }
@@ -87,3 +87,6 @@ lettre_email = { git = 'https://github.com/lettre/lettre', rev = 'c988b1760ad81'
# Version 0.1.2 from crates.io lacks a commit that fixes a certificate error
u2f = { git = 'https://github.com/wisespace-io/u2f-rs', rev = '193de35093a44' }
+
+# Allows optional libusb support
+yubico = { git = 'https://github.com/dani-garcia/yubico-rs' }