aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel García <[email protected]>2018-09-19 21:43:03 +0200
committerDaniel García <[email protected]>2018-09-19 21:43:03 +0200
commit638a0fd3c3226006fce847a64292f4f0800a23c9 (patch)
tree1a50dc34d0a17cb56a9682a91a15e39d74fe48fd /Cargo.toml
parentebb66c374e3b8b6404929c4b90bfaab4a48f4fae (diff)
downloadvaultwarden-638a0fd3c3226006fce847a64292f4f0800a23c9.tar.gz
vaultwarden-638a0fd3c3226006fce847a64292f4f0800a23c9.zip
Updated dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 48673abd..59e5232e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,7 +10,7 @@ rocket_codegen = "0.3.16"
rocket_contrib = "0.3.16"
# HTTP client
-reqwest = "0.8.8"
+reqwest = "0.9.0"
# multipart/form-data support
multipart = "0.15.3"
@@ -25,12 +25,12 @@ rmpv = "0.4.0"
chashmap = "2.2.0"
# A generic serialization/deserialization framework
-serde = "1.0.77"
-serde_derive = "1.0.77"
-serde_json = "1.0.27"
+serde = "1.0.79"
+serde_derive = "1.0.79"
+serde_json = "1.0.28"
# A safe, extensible ORM and Query builder
-diesel = { version = "1.3.2", features = ["sqlite", "chrono", "r2d2"] }
+diesel = { version = "1.3.3", features = ["sqlite", "chrono", "r2d2"] }
diesel_migrations = { version = "1.3.0", features = ["sqlite"] }
# Bundled SQLite
@@ -40,7 +40,7 @@ libsqlite3-sys = { version = "0.9.3", features = ["bundled"] }
ring = { version = "= 0.11.0", features = ["rsa_signing"] }
# UUID generation
-uuid = { version = "0.7.0", features = ["v4"] }
+uuid = { version = "0.7.1", features = ["v4"] }
# Date and time library for Rust
chrono = "0.4.6"
@@ -64,13 +64,13 @@ dotenv = { version = "0.13.0", default-features = false }
lazy_static = "1.1.0"
# Numerical libraries
-num-traits = "0.2.5"
+num-traits = "0.2.6"
num-derive = "0.2.2"
# Email libraries
lettre = "0.8.2"
lettre_email = "0.8.2"
-native-tls = "0.1.5"
+native-tls = "0.2.1"
fast_chemail = "0.9.5"
# Number encoding library