aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2023-07-04 20:12:50 +0200
committerBlackDex <[email protected]>2023-07-04 20:12:50 +0200
commit0a6b797e6ef789909d124eecad9179275f421873 (patch)
tree9cc069fc69cee24f1335f2ecfd3002d8535d3009 /Cargo.toml
parent19e671ff25bffa47424b5af44264c2c74c2cc84b (diff)
downloadvaultwarden-0a6b797e6ef789909d124eecad9179275f421873.tar.gz
vaultwarden-0a6b797e6ef789909d124eecad9179275f421873.zip
Update crates and small clippy fix
- Update all crates - Remove async which is reported by clippy in v1.72.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6a954008..8231c354 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,7 +52,7 @@ once_cell = "1.18.0"
# Numerical libraries
num-traits = "0.2.15"
-num-derive = "0.3.3"
+num-derive = "0.4.0"
# Web framework
rocket = { version = "0.5.0-rc.3", features = ["tls", "json"], default-features = false }
@@ -68,11 +68,11 @@ dashmap = "5.4.0"
# Async futures
futures = "0.3.28"
-tokio = { version = "1.28.2", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
+tokio = { version = "1.29.1", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.164", features = ["derive"] }
-serde_json = "1.0.97"
+serde = { version = "1.0.166", features = ["derive"] }
+serde_json = "1.0.99"
# A safe, extensible ORM and Query builder
diesel = { version = "2.1.0", features = ["chrono", "r2d2"] }
@@ -87,11 +87,11 @@ rand = { version = "0.8.5", features = ["small_rng"] }
ring = "0.16.20"
# UUID generation
-uuid = { version = "1.3.4", features = ["v4"] }
+uuid = { version = "1.4.0", features = ["v4"] }
# Date and time libraries
chrono = { version = "0.4.26", features = ["clock", "serde"], default-features = false }
-chrono-tz = "0.8.2"
+chrono-tz = "0.8.3"
time = "0.3.22"
# Job scheduler
@@ -117,7 +117,7 @@ url = "2.4.0"
# Email libraries
lettre = { version = "0.10.4", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
-percent-encoding = "2.2.0" # URL encoding library used for URL's in the emails
+percent-encoding = "2.3.0" # URL encoding library used for URL's in the emails
email_address = "0.2.4"
# HTML Template library
@@ -146,7 +146,7 @@ openssl = "0.10.55"
pico-args = "0.5.0"
# Macro ident concatenation
-paste = "1.0.12"
+paste = "1.0.13"
governor = "0.5.1"
# Check client versions for specific features.