aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel García <[email protected]>2022-05-20 23:39:47 +0200
committerDaniel García <[email protected]>2022-10-23 00:49:23 +0200
commit8409b31d6be818836434e57ab2200c85d17df4ed (patch)
tree0d6b6e7a576a4cee886d146adc4a10fdd55c2a5c /Cargo.toml
parentb878495d647b62b8ca4fd7c7d111ce34ef59266b (diff)
downloadvaultwarden-8409b31d6be818836434e57ab2200c85d17df4ed.tar.gz
vaultwarden-8409b31d6be818836434e57ab2200c85d17df4ed.zip
Update to diesel2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f2ef16cb..6051c385 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,7 +42,7 @@ tracing = { version = "0.1.37", features = ["log"] } # Needed to have lettre and
backtrace = "0.3.66" # Logging panics to logfile instead stderr only
# A `dotenv` implementation for Rust
-dotenvy = { version = "0.15.5", default-features = false }
+dotenvy = { version = "0.15.6", default-features = false }
# Lazy initialization
once_cell = "1.15.0"
@@ -60,19 +60,19 @@ rmpv = "1.0.0" # MessagePack library
dashmap = "5.4.0"
# Async futures
-futures = "0.3.24"
+futures = "0.3.25"
tokio = { version = "1.21.2", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time"] }
# A generic serialization/deserialization framework
serde = { version = "1.0.145", features = ["derive"] }
-serde_json = "1.0.86"
+serde_json = "1.0.87"
# A safe, extensible ORM and Query builder
-diesel = { version = "1.4.8", features = ["chrono", "r2d2"] }
-diesel_migrations = "1.4.0"
+diesel = { version = "2.0.2", features = ["chrono", "r2d2"] }
+diesel_migrations = "2.0.0"
# Bundled SQLite
-libsqlite3-sys = { version = "0.22.2", features = ["bundled"], optional = true }
+libsqlite3-sys = { version = "0.25.1", features = ["bundled"], optional = true }
# Crypto-related libraries
rand = { version = "0.8.5", features = ["small_rng"] }
@@ -83,7 +83,7 @@ uuid = { version = "1.2.1", features = ["v4"] }
# Date and time libraries
chrono = { version = "0.4.22", features = ["clock", "serde"], default-features = false }
-chrono-tz = "0.6.3"
+chrono-tz = "0.7.0"
time = "0.3.15"
# Job scheduler