aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBlackDex <[email protected]>2023-06-21 22:01:05 +0200
committerBlackDex <[email protected]>2023-06-21 22:01:05 +0200
commit84a23008f44b089fbb6a2e3adb0bec6117c2c4c3 (patch)
tree59b4e9e022ea74cc92a124468650207277e4a890 /Cargo.toml
parent44e9e1a58ed37bf4b352bb499fd3e97adcd3b26b (diff)
downloadvaultwarden-84a23008f44b089fbb6a2e3adb0bec6117c2c4c3.tar.gz
vaultwarden-84a23008f44b089fbb6a2e3adb0bec6117c2c4c3.zip
Update crates and workflow
- Updated all the crates - Updated workflow actions - Set cargo registry to sparse
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 14 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6f38b5a9..6a954008 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -40,7 +40,7 @@ syslog = "6.1.0"
[dependencies]
# Logging
-log = "0.4.18"
+log = "0.4.19"
fern = { version = "0.6.2", features = ["syslog-6"] }
tracing = { version = "0.1.37", features = ["log"] } # Needed to have lettre and webauthn-rs trace logging to work
@@ -57,7 +57,7 @@ num-derive = "0.3.3"
# Web framework
rocket = { version = "0.5.0-rc.3", features = ["tls", "json"], default-features = false }
# rocket_ws = { version ="0.1.0-rc.3" }
-rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = "a298f8446be64d58cbb7345b6baa026aa4b672b4" } # v0.5 branch
+rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = "ce441b5f46fdf5cd99cb32b8b8638835e4c2a5fa" } # v0.5 branch
# WebSockets libraries
tokio-tungstenite = "0.19.0"
@@ -71,8 +71,8 @@ futures = "0.3.28"
tokio = { version = "1.28.2", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.163", features = ["derive"] }
-serde_json = "1.0.96"
+serde = { version = "1.0.164", features = ["derive"] }
+serde_json = "1.0.97"
# A safe, extensible ORM and Query builder
diesel = { version = "2.1.0", features = ["chrono", "r2d2"] }
@@ -87,12 +87,12 @@ rand = { version = "0.8.5", features = ["small_rng"] }
ring = "0.16.20"
# UUID generation
-uuid = { version = "1.3.3", features = ["v4"] }
+uuid = { version = "1.3.4", features = ["v4"] }
# Date and time libraries
chrono = { version = "0.4.26", features = ["clock", "serde"], default-features = false }
chrono-tz = "0.8.2"
-time = "0.3.21"
+time = "0.3.22"
# Job scheduler
job_scheduler_ng = "2.0.4"
@@ -113,7 +113,7 @@ yubico = { version = "0.11.0", features = ["online-tokio"], default-features = f
webauthn-rs = "0.3.2"
# Handling of URL's for WebAuthn and favicons
-url = "2.3.1"
+url = "2.4.0"
# Email libraries
lettre = { version = "0.10.4", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
@@ -127,9 +127,9 @@ handlebars = { version = "4.3.7", features = ["dir_source"] }
reqwest = { version = "0.11.18", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
# Favicon extraction libraries
-html5gum = "0.5.2"
-regex = { version = "1.8.3", features = ["std", "perf", "unicode-perl"], default-features = false }
-data-url = "0.2.0"
+html5gum = "0.5.3"
+regex = { version = "1.8.4", features = ["std", "perf", "unicode-perl"], default-features = false }
+data-url = "0.3.0"
bytes = "1.4.0"
# Cache function results (Used for version check and favicon fetching)
@@ -137,10 +137,10 @@ cached = "0.44.0"
# Used for custom short lived cookie jar during favicon extraction
cookie = "0.16.2"
-cookie_store = "0.19.0"
+cookie_store = "0.19.1"
# Used by U2F, JWT and PostgreSQL
-openssl = "0.10.54"
+openssl = "0.10.55"
# CLI argument parsing
pico-args = "0.5.0"
@@ -164,8 +164,8 @@ argon2 = "0.5.0"
rpassword = "7.2.0"
[patch.crates-io]
-rocket = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'a298f8446be64d58cbb7345b6baa026aa4b672b4' } # v0.5 branch
-# rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'a298f8446be64d58cbb7345b6baa026aa4b672b4' } # v0.5 branch
+rocket = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'ce441b5f46fdf5cd99cb32b8b8638835e4c2a5fa' } # v0.5 branch
+# rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = 'ce441b5f46fdf5cd99cb32b8b8638835e4c2a5fa' } # v0.5 branch
# Strip debuginfo from the release builds
# Also enable thin LTO for some optimizations