diff options
author | BlackDex <[email protected]> | 2023-03-04 19:18:38 +0100 |
---|---|---|
committer | BlackDex <[email protected]> | 2023-03-07 09:17:42 +0100 |
commit | 0c0e632bc99e707991da1af01d111580d1571ff9 (patch) | |
tree | f11cf7657272c127acee2421c8b990e23f9eb737 /Cargo.toml | |
parent | a13a5bd1d8c3fea3fce80eba6e8c3aa8880855dd (diff) | |
download | vaultwarden-0c0e632bc99e707991da1af01d111580d1571ff9.tar.gz vaultwarden-0c0e632bc99e707991da1af01d111580d1571ff9.zip |
Upd Crates, Rust, MSRV, GHA and remove Backtrace
- Changed MSRV to v1.65.
Discussed this with @dani-garcia, and we will support **N-2**.
This is/will be the same as for the `time` crate we use.
Also updated the wiki regarding this https://github.com/dani-garcia/vaultwarden/wiki/Building-binary
- Removed backtrace crate in favor of `std::backtrace` stable since v1.65
- Updated Rust to v1.67.1
- Updated all the crates
- Updated the GHA action versions
- Adjusted the GHA MSRV build to extract the MSRV from `Cargo.toml`
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 18 |
1 files changed, 10 insertions, 8 deletions
@@ -3,7 +3,7 @@ name = "vaultwarden" version = "1.0.0" authors = ["Daniel GarcĂa <[email protected]>"] edition = "2021" -rust-version = "1.61.0" +rust-version = "1.65.0" resolver = "2" repository = "https://github.com/dani-garcia/vaultwarden" @@ -44,8 +44,6 @@ log = "0.4.17" fern = { version = "0.6.1", features = ["syslog-6"] } tracing = { version = "0.1.37", features = ["log"] } # Needed to have lettre and webauthn-rs trace logging to work -backtrace = "0.3.67" # Logging panics to logfile instead stderr only - # A `dotenv` implementation for Rust dotenvy = { version = "0.15.6", default-features = false } @@ -68,11 +66,11 @@ dashmap = "5.4.0" # Async futures futures = "0.3.26" -tokio = { version = "1.25.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } +tokio = { version = "1.26.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } # A generic serialization/deserialization framework serde = { version = "1.0.152", features = ["derive"] } -serde_json = "1.0.93" +serde_json = "1.0.94" # A safe, extensible ORM and Query builder diesel = { version = "2.0.3", features = ["chrono", "r2d2"] } @@ -92,7 +90,7 @@ uuid = { version = "1.3.0", features = ["v4"] } # Date and time libraries chrono = { version = "0.4.23", features = ["clock", "serde"], default-features = false } chrono-tz = "0.8.1" -time = "0.3.19" +time = "0.3.20" # Job scheduler job_scheduler_ng = "2.0.4" @@ -146,7 +144,7 @@ openssl = "0.10.45" pico-args = "0.5.0" # Macro ident concatenation -paste = "1.0.11" +paste = "1.0.12" governor = "0.5.1" # Check client versions for specific features. @@ -158,7 +156,7 @@ mimalloc = { version = "0.1.34", features = ["secure"], default-features = false which = "4.4.0" # Argon2 library with support for the PHC format -argon2 = "0.5.0-pre.0" +argon2 = "0.5.0" # Reading a password from the cli for generating the Argon2id ADMIN_TOKEN rpassword = "7.2" @@ -173,3 +171,7 @@ lto = "thin" # This is a huge speed improvement during testing [profile.dev.package.argon2] opt-level = 3 + +# A little bit of a speedup +[profile.dev] +split-debuginfo = "unpacked" |