diff options
author | Daniel García <[email protected]> | 2024-03-17 14:25:49 +0100 |
---|---|---|
committer | Daniel García <[email protected]> | 2024-03-17 14:25:49 +0100 |
commit | 6d73f30b4f355437fdfb96bb9e146e4523641df1 (patch) | |
tree | a9e0fd82f736ec39cfe9688d2b7670b81b688905 /Cargo.toml | |
parent | d0c22b9fc90ae52aedbbccdafe9915bd0bdb0d84 (diff) | |
download | vaultwarden-6d73f30b4f355437fdfb96bb9e146e4523641df1.tar.gz vaultwarden-6d73f30b4f355437fdfb96bb9e146e4523641df1.zip |
Update crates
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 14 |
1 files changed, 7 insertions, 7 deletions
@@ -40,7 +40,7 @@ syslog = "6.1.0" [dependencies] # Logging -log = "0.4.20" +log = "0.4.21" fern = { version = "0.6.2", features = ["syslog-6", "reopen-1"] } tracing = { version = "0.1.40", features = ["log"] } # Needed to have lettre and webauthn-rs trace logging to work @@ -53,7 +53,7 @@ once_cell = "1.19.0" # Numerical libraries num-traits = "0.2.18" num-derive = "0.4.2" -bigdecimal = "0.4.2" +bigdecimal = "0.4.3" # Web framework rocket = { version = "0.5.0", features = ["tls", "json"], default-features = false } @@ -75,7 +75,7 @@ serde = { version = "1.0.197", features = ["derive"] } serde_json = "1.0.114" # A safe, extensible ORM and Query builder -diesel = { version = "2.1.4", features = ["chrono", "r2d2", "numeric"] } +diesel = { version = "2.1.5", features = ["chrono", "r2d2", "numeric"] } diesel_migrations = "2.1.0" diesel_logger = { version = "0.3.0", optional = true } @@ -124,7 +124,7 @@ email_address = "0.2.4" handlebars = { version = "5.1.0", features = ["dir_source"] } # HTTP client (Used for favicons, version check, DUO and HIBP API) -reqwest = { version = "0.11.24", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns", "native-tls-alpn"] } +reqwest = { version = "0.11.26", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns", "native-tls-alpn"] } # Favicon extraction libraries html5gum = "0.5.7" @@ -133,11 +133,11 @@ data-url = "0.3.1" bytes = "1.5.0" # Cache function results (Used for version check and favicon fetching) -cached = { version = "0.48.1", features = ["async"] } +cached = { version = "0.49.2", features = ["async"] } # Used for custom short lived cookie jar during favicon extraction -cookie = "0.17.0" -cookie_store = "0.20.0" +cookie = "0.18.0" +cookie_store = "0.21.0" # Used by U2F, JWT and PostgreSQL openssl = "0.10.64" |