aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 8 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d523d704..736a83ba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,12 +5,12 @@ authors = ["Daniel GarcĂ­a <[email protected]>"]
[dependencies]
# Web framework for nightly with a focus on ease-of-use, expressibility, and speed.
-rocket = { version = "0.3.16", features = ["tls"] }
-rocket_codegen = "0.3.16"
-rocket_contrib = "0.3.16"
+rocket = { version = "0.3.17", features = ["tls"] }
+rocket_codegen = "0.3.17"
+rocket_contrib = "0.3.17"
# HTTP client
-reqwest = "0.9.0"
+reqwest = "0.9.2"
# multipart/form-data support
multipart = "0.15.3"
@@ -27,7 +27,7 @@ chashmap = "2.2.0"
# A generic serialization/deserialization framework
serde = "1.0.79"
serde_derive = "1.0.79"
-serde_json = "1.0.28"
+serde_json = "1.0.31"
# A safe, extensible ORM and Query builder
diesel = { version = "1.3.3", features = ["sqlite", "chrono", "r2d2"] }
@@ -65,13 +65,12 @@ lazy_static = "1.1.0"
# Numerical libraries
num-traits = "0.2.6"
-num-derive = "0.2.2"
+num-derive = "0.2.3"
# Email libraries
lettre = "0.9.0"
lettre_email = "0.9.0"
native-tls = "0.2.1"
-fast_chemail = "0.9.5"
# Number encoding library
byteorder = "1.2.6"
@@ -80,8 +79,8 @@ byteorder = "1.2.6"
# Make jwt use ring 0.11, to match rocket
jsonwebtoken = { path = "libs/jsonwebtoken" }
rmp = { git = 'https://github.com/dani-garcia/msgpack-rust' }
-lettre = { git = 'https://github.com/lettre/lettre', rev = 'fc91bb6ee8f9a' }
-lettre_email = { git = 'https://github.com/lettre/lettre', rev = 'fc91bb6ee8f9a' }
+lettre = { git = 'https://github.com/lettre/lettre', rev = 'c988b1760ad81' }
+lettre_email = { git = 'https://github.com/lettre/lettre', rev = 'c988b1760ad81' }
# Version 0.1.2 from crates.io lacks a commit that fixes a certificate error
u2f = { git = 'https://github.com/wisespace-io/u2f-rs', rev = '193de35093a44' }