aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorAndrea Pappacoda <[email protected]>2021-09-18 00:07:23 +0200
committerAndrea Pappacoda <[email protected]>2021-09-18 00:12:33 +0200
commit0000938f5db5875ad9c95cc9b8ed2ea9fe522127 (patch)
treeed0ba378be28b501e10b305dd6a2130d96355c45 /meson.build
parent757e4063f6464740b8ff4a2cae9136d2f8458020 (diff)
downloadxbyak-0000938f5db5875ad9c95cc9b8ed2ea9fe522127.tar.gz
xbyak-0000938f5db5875ad9c95cc9b8ed2ea9fe522127.zip
build: add Meson support
This allows Meson users to use xbyak more easly, while it also provides a pkg-config file generator, useful to Linux distributions
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..205d378
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,26 @@
+# SPDX-FileCopyrightText: 2021 Andrea Pappacoda
+#
+# SPDX-License-Identifier: BSD-3-Clause
+
+project(
+ 'xbyak',
+ 'cpp',
+ version: '6.00',
+ license: 'BSD-3-Clause',
+ default_options: 'b_ndebug=if-release'
+)
+
+install_subdir('xbyak', install_dir: get_option('includedir'))
+
+xbyak_dep = declare_dependency(include_directories: include_directories('.'))
+
+if meson.version().version_compare('>=0.54.0')
+ meson.override_dependency('xbyak', xbyak_dep)
+endif
+
+import('pkgconfig').generate(
+ name: 'xbyak',
+ description: 'JIT assembler for x86(IA32), x64(AMD64, x86-64)',
+ version: meson.project_version(),
+ url: 'https://github.com/herumi/xbyak'
+)