aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew JÄ™drzejewski-Szmek <[email protected]>2024-03-06 18:15:57 +0100
committerZbigniew JÄ™drzejewski-Szmek <[email protected]>2024-03-06 18:25:01 +0100
commit9f535729159baf467c3bd8dc7ec017a40289a12c (patch)
tree6c8a45859d54db056a7a5838ffc017510249aa0c /meson.build
parentc7c1eac070851068d7adc3a67ad2efd196145687 (diff)
downloadxbyak-9f535729159baf467c3bd8dc7ec017a40289a12c.tar.gz
xbyak-9f535729159baf467c3bd8dc7ec017a40289a12c.zip
Install cmake files into an arch-independent directory
The justification is similar as for the .pc file: the include directory is arch-independent, so the cmake description should be too.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9eb6794..e5a7c3d 100644
--- a/meson.build
+++ b/meson.build
@@ -28,12 +28,14 @@ import('pkgconfig').generate(
dataonly: true,
)
+shared_cmake_dir = get_option('prefix') / 'share/cmake/xbyak'
if meson.version().version_compare('>=0.50.0')
cmake = import('cmake')
cmake.write_basic_package_version_file(
name: meson.project_name(),
- version: meson.project_version()
+ version: meson.project_version(),
+ install_dir: shared_cmake_dir,
)
cmake_conf = configuration_data()
@@ -43,6 +45,7 @@ if meson.version().version_compare('>=0.50.0')
cmake.configure_package_config_file(
name: meson.project_name(),
input: 'cmake'/'meson-config.cmake.in',
- configuration: cmake_conf
+ configuration: cmake_conf,
+ install_dir: shared_cmake_dir,
)
endif