aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2023-10-13 20:20:02 +0100
committerVaxry <[email protected]>2023-10-13 20:20:02 +0100
commit2d5e1de7f3986294d429cb97987413339094a09b (patch)
treeb214223c01d9690893d63292527ce61abcb0a609 /CMakeLists.txt
parentbf070adf57d34c3f291ace2e0532830988629735 (diff)
downloadHyprland-2d5e1de7f3986294d429cb97987413339094a09b.tar.gz
Hyprland-2d5e1de7f3986294d429cb97987413339094a09b.zip
add dep hl <- wlroots
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6b67f66..04008a8b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,7 @@ pkg_check_modules(deps REQUIRED IMPORTED_TARGET wayland-server wayland-client wa
file(GLOB_RECURSE SRCFILES CONFIGURE_DEPENDS "src/*.cpp")
add_executable(Hyprland ${SRCFILES})
+add_dependencies(Hyprland wlroots)
if(CMAKE_BUILD_TYPE MATCHES Debug OR CMAKE_BUILD_TYPE MATCHES DEBUG)
message(STATUS "Setting debug flags")