aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvaxerski <[email protected]>2023-02-19 13:45:56 +0000
committervaxerski <[email protected]>2023-02-19 13:45:56 +0000
commit38c25bb50d76409193db2438db60369f3868edf9 (patch)
tree6450e68c394691c222209addb76d9940998a5c95 /CMakeLists.txt
parent6548439f6ce205795bfe55fc22d30830c725e0d2 (diff)
downloadHyprland-38c25bb50d76409193db2438db60369f3868edf9.tar.gz
Hyprland-38c25bb50d76409193db2438db60369f3868edf9.zip
Added a crash reporter
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4297b451..b2e4b8b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,6 +100,9 @@ target_compile_definitions(Hyprland PRIVATE "-DGIT_BRANCH=\"${GIT_BRANCH}\"")
target_compile_definitions(Hyprland PRIVATE "-DGIT_COMMIT_MESSAGE=\"${GIT_COMMIT_MESSAGE}\"")
target_compile_definitions(Hyprland PRIVATE "-DGIT_DIRTY=\"${GIT_DIRTY}\"")
+ADD_LINK_OPTIONS( -rdynamic )
+SET(CMAKE_ENABLE_EXPORTS TRUE)
+
target_link_libraries(Hyprland rt)
set(CPACK_PROJECT_NAME ${PROJECT_NAME})