aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2023-01-06 16:21:42 +0200
committerMihai Fufezan <[email protected]>2023-01-06 16:22:00 +0200
commita54247125f91358ef717ecee8801c4acebdb0b55 (patch)
tree927cb0a28b89aac2af1bae67ba79b586d3fc76b4 /CMakeLists.txt
parent98ce867104b855824ee218296f91664e1fd60545 (diff)
downloadHyprland-a54247125f91358ef717ecee8801c4acebdb0b55.tar.gz
Hyprland-a54247125f91358ef717ecee8801c4acebdb0b55.zip
Build: use props file for versioning
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3752eaf..04d9ec23 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,12 @@
cmake_minimum_required(VERSION 3.4)
+
+# Get version
+file(READ ${CMAKE_CURRENT_SOURCE_DIR}/props.json PROPS)
+string(JSON VER GET ${PROPS} version)
+
project(Hyprland
DESCRIPTION "A Modern C++ Wayland Compositor"
+ VERSION ${VER}
)
set(CMAKE_MESSAGE_LOG_LEVEL "STATUS")