aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Beich <[email protected]>2023-02-20 14:15:15 +0000
committerGitHub <[email protected]>2023-02-20 14:15:15 +0000
commit474ada9267ccb98015991ee9d0d93fbb5da72034 (patch)
treeb53e9f2f16e47974e3a42d275b457d0aa9542fe4 /CMakeLists.txt
parent784cdd76380b844bec286416de297daca3fbcdc7 (diff)
downloadHyprland-474ada9267ccb98015991ee9d0d93fbb5da72034.tar.gz
Hyprland-474ada9267ccb98015991ee9d0d93fbb5da72034.zip
Unbreak CrashReporter on FreeBSD (#1589)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 065f5894..b59b455e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,12 @@ file(GLOB_RECURSE SRCFILES "src/*.cpp")
add_executable(Hyprland ${SRCFILES})
+include(CheckLibraryExists)
+check_library_exists(execinfo backtrace "" HAVE_LIBEXECINFO)
+if(HAVE_LIBEXECINFO)
+ target_link_libraries(Hyprland PRIVATE execinfo)
+endif()
+
IF(LEGACY_RENDERER MATCHES true)
message(STATUS "Using the legacy GLES2 renderer!")
add_definitions( -DLEGACY_RENDERER )