aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYang, Ying-chao <[email protected]>2024-08-12 03:38:16 +0800
committerGitHub <[email protected]>2024-08-11 20:38:16 +0100
commit118d4e1001d5847aa42d1e5d5fa9623954ae751d (patch)
tree9107373ffb637a459958eb1bb1523df7d0e1e3ed /CMakeLists.txt
parent511eea71c60e10f3d3d757a376f1ca98b9034ae0 (diff)
downloadHyprland-118d4e1001d5847aa42d1e5d5fa9623954ae751d.tar.gz
Hyprland-118d4e1001d5847aa42d1e5d5fa9623954ae751d.zip
install: Prepend ${DESTDIR} when creating hyprland symbolic link (fixes #7280). (#7281)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8c45bbe..f26a5c3c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -330,7 +330,7 @@ install(
CODE "execute_process( \
COMMAND ${CMAKE_COMMAND} -E create_symlink \
${CMAKE_INSTALL_FULL_BINDIR}/Hyprland \
- ${CMAKE_INSTALL_FULL_BINDIR}/hyprland
+ \"\$ENV{DESTDIR}${CMAKE_INSTALL_FULL_BINDIR}/hyprland\" \
)")
# session file