aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni500github <[email protected]>2024-10-11 13:19:16 +0200
committerGitHub <[email protected]>2024-10-11 12:19:16 +0100
commit7564b26b7d386d248eaa47c1a481c09eefd8e3ca (patch)
treea69321b879c4f4b2ab44466963a3126f981a9864 /CMakeLists.txt
parent178a300eeaf006fed4c8c9a599657b4530f65559 (diff)
downloadHyprland-7564b26b7d386d248eaa47c1a481c09eefd8e3ca.tar.gz
Hyprland-7564b26b7d386d248eaa47c1a481c09eefd8e3ca.zip
internal: improve version query and define HYPRLAND_VERSION (#8034)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4de449dc..df919d76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,8 @@ else()
message(STATUS "Configuring Hyprland in Release with CMake")
endif()
+add_compile_definitions(HYPRLAND_VERSION="${HYPRLAND_VERSION}")
+
include_directories(. "src/" "protocols/")
set(CMAKE_CXX_STANDARD 26)