aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvaxerski <[email protected]>2022-04-13 17:34:13 +0200
committervaxerski <[email protected]>2022-04-13 17:34:13 +0200
commit084e922642686cac2b03ea88fceb09c0506d7ed2 (patch)
treeb886ea37a2f1fec275da14d62fa32c94288e3d6c /CMakeLists.txt
parent4b7a1a471f5eb4f52a6dac2379c17b2f85b49e61 (diff)
downloadHyprland-084e922642686cac2b03ea88fceb09c0506d7ed2.tar.gz
Hyprland-084e922642686cac2b03ea88fceb09c0506d7ed2.zip
Added legacy GLES2 renderer option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 032160de..943a3f8c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,11 @@ file(GLOB_RECURSE SRCFILES "src/*.cpp")
add_executable(Hyprland ${SRCFILES})
+IF(LEGACY_RENDERER MATCHES true)
+ message(STATUS "Using the legacy GLES2 renderer!")
+ add_definitions( -DLEGACY_RENDERER )
+ENDIF(LEGACY_RENDERER MATCHES true)
+
IF(CMAKE_BUILD_TYPE MATCHES Debug OR CMAKE_BUILD_TYPE MATCHES DEBUG)
message(STATUS "Configuring Hyprland in Debug with CMake!")
ELSE()