aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgiskard <[email protected]>2024-05-16 00:13:56 +0800
committerMihai Fufezan <[email protected]>2024-05-21 20:36:07 +0300
commit3c907f783027328cf90fae45ff51978c1f123418 (patch)
treebf4a4f52edeeda2d988ca166ad267aface9a10c8 /CMakeLists.txt
parent4daa5c06587390c5c6835275ccbfc645bacc0052 (diff)
downloadHyprland-3c907f783027328cf90fae45ff51978c1f123418.tar.gz
Hyprland-3c907f783027328cf90fae45ff51978c1f123418.zip
build: update meson, cmake setup
- meson . fix run_command() check warning . drop lines for compatability, as it's already using c++23 - cmake . generate `compile_commands.json` by default . position independent build: __FILE__
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43927fbe..858502cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ project(Hyprland
set(HYPRLAND_VERSION ${VER})
set(PREFIX ${CMAKE_INSTALL_PREFIX})
set(INCLUDEDIR ${CMAKE_INSTALL_INCLUDEDIR})
-configure_file(hyprland.pc.in hyprland.pc @ONLY)
+configure_file(hyprland.pc.in hyprland.pc @ONLY)
set(CMAKE_MESSAGE_LOG_LEVEL "STATUS")
@@ -90,9 +90,12 @@ include_directories(
"protocols/")
set(CMAKE_CXX_STANDARD 23)
add_compile_definitions(WLR_USE_UNSTABLE)
-add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-value -Wno-missing-field-initializers -Wno-narrowing -Wno-pointer-arith)
+add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-value
+ -Wno-missing-field-initializers -Wno-narrowing -Wno-pointer-arith
+ -fmacro-prefix-map=${CMAKE_SOURCE_DIR}/=)
set(CMAKE_EXECUTABLE_ENABLE_EXPORTS TRUE)
+set(CMAKE_EXPORT_COMPILE_COMMANDS TRUE)
message(STATUS "Checking deps...")