aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvaxerski <[email protected]>2022-07-06 16:50:11 +0200
committervaxerski <[email protected]>2022-07-06 16:50:11 +0200
commitf9756d10d4d1c5ea7737cf3a237b1f966d6b7a01 (patch)
treec88df1366e9af3097edd2025494564ea92e0cb2a /CMakeLists.txt
parent0d7a8cca790e8fa71a83e4dce09fbe5a0af38cbc (diff)
downloadHyprland-f9756d10d4d1c5ea7737cf3a237b1f966d6b7a01.tar.gz
Hyprland-f9756d10d4d1c5ea7737cf3a237b1f966d6b7a01.zip
changed C++ std to C++23, use std::string::contains
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c93a9f32..e7c39e93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,7 @@ execute_process(
include_directories(. PRIVATE "subprojects/wlroots/include/")
include_directories(. PRIVATE "subprojects/wlroots/build/include/")
-add_compile_options(-std=c++20 -DWLR_USE_UNSTABLE )
+add_compile_options(-std=c++2b -DWLR_USE_UNSTABLE )
add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-value -Wno-missing-field-initializers -Wno-narrowing)
find_package(Threads REQUIRED)