aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2023-10-31 21:45:27 +0000
committerVaxry <[email protected]>2023-10-31 21:45:27 +0000
commit6914103289125c4c909c1f17e53f9bdd02a66e62 (patch)
tree3f208e9df65501577e3a4847d71858901152d935 /CMakeLists.txt
parentab5497a0c9e9269b1036a0bede42cbd0bbfd94b9 (diff)
downloadHyprland-6914103289125c4c909c1f17e53f9bdd02a66e62.tar.gz
Hyprland-6914103289125c4c909c1f17e53f9bdd02a66e62.zip
cmake: set asan for only hyprland not others
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 228e40c4..31a1646b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,7 +116,7 @@ if(CMAKE_BUILD_TYPE MATCHES Debug OR CMAKE_BUILD_TYPE MATCHES DEBUG)
message(STATUS "Enabling ASan")
target_link_libraries(Hyprland asan)
- add_compile_options(-fsanitize=address)
+ target_compile_options(Hyprland PUBLIC -fsanitize=address)
endif()
if(USE_TRACY)