aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-08-22 14:30:10 +0300
committerMihai Fufezan <[email protected]>2024-08-22 14:30:10 +0300
commit4fa63104c94ca5e2d2e3baaf3b3926db246b964c (patch)
tree14c39fc8d3e18b540e8ee81cba93fd3c23c138b4 /CMakeLists.txt
parenta437e44a6af8e8f42966ffe3a26c1d562fce6b33 (diff)
downloadHyprland-4fa63104c94ca5e2d2e3baaf3b3926db246b964c.tar.gz
Hyprland-4fa63104c94ca5e2d2e3baaf3b3926db246b964c.zip
Nix: exclude wayland-scanner until next staging merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1373e07..e8ea4797 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,6 +52,8 @@ find_package(PkgConfig REQUIRED)
pkg_get_variable(WAYLAND_PROTOCOLS_DIR wayland-protocols pkgdatadir)
message(STATUS "Found wayland-protocols at ${WAYLAND_PROTOCOLS_DIR}")
pkg_get_variable(WAYLAND_SCANNER_PKGDATA_DIR wayland-scanner pkgdatadir)
+message(
+ STATUS "Found wayland-scanner pkgdatadir at ${WAYLAND_SCANNER_PKGDATA_DIR}")
if(CMAKE_BUILD_TYPE MATCHES Debug OR CMAKE_BUILD_TYPE MATCHES DEBUG)
message(STATUS "Configuring Hyprland in Debug with CMake")
@@ -87,11 +89,7 @@ else()
endif()
find_package(OpenGL REQUIRED COMPONENTS ${GLES_VERSION})
-pkg_check_modules(
- hyprctl_deps
- REQUIRED
- IMPORTED_TARGET
- hyprutils>=0.2.1)
+pkg_check_modules(hyprctl_deps REQUIRED IMPORTED_TARGET hyprutils>=0.2.1)
pkg_check_modules(
deps
@@ -258,8 +256,9 @@ function(protocolWayland)
add_custom_command(
OUTPUT ${CMAKE_SOURCE_DIR}/protocols/wayland.cpp
${CMAKE_SOURCE_DIR}/protocols/wayland.hpp
- COMMAND hyprwayland-scanner --wayland-enums
- ${WAYLAND_SCANNER_PKGDATA_DIR}/wayland.xml ${CMAKE_SOURCE_DIR}/protocols/
+ COMMAND
+ hyprwayland-scanner --wayland-enums
+ ${WAYLAND_SCANNER_PKGDATA_DIR}/wayland.xml ${CMAKE_SOURCE_DIR}/protocols/
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
target_sources(Hyprland PRIVATE protocols/wayland.cpp protocols/wayland.hpp)
target_sources(generate-protocol-headers