aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-08-29 23:30:12 +0200
committerGitHub <[email protected]>2024-08-29 23:30:12 +0200
commit604eb21a7e55d85ec7f6cb8cba39fc4c20a07a9d (patch)
tree7b31fb7e21d779fee2911aa7430feed1ec3774d6 /CMakeLists.txt
parent92a0dd164e9cc74060b63abae67b0204b6b6074c (diff)
downloadHyprland-604eb21a7e55d85ec7f6cb8cba39fc4c20a07a9d.tar.gz
Hyprland-604eb21a7e55d85ec7f6cb8cba39fc4c20a07a9d.zip
renderer: better lockscreen dead behavior (#7574)
--------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8ea4797..84a856b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -336,12 +336,14 @@ install(
install(FILES ${CMAKE_SOURCE_DIR}/example/hyprland.desktop
DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/wayland-sessions)
-# allow Hyprland to find wallpapers
+# allow Hyprland to find assets
add_compile_definitions(DATAROOTDIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}")
-# wallpapers
-file(GLOB_RECURSE WALLPAPERS "assets/wall*")
-install(FILES ${WALLPAPERS} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/hypr)
+# installable assets
+file(GLOB_RECURSE INSTALLABLE_ASSETS "assets/install/*")
+list(FILTER INSTALLABLE_ASSETS EXCLUDE REGEX "meson.build")
+install(FILES ${INSTALLABLE_ASSETS}
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/hypr)
# default config
install(FILES ${CMAKE_SOURCE_DIR}/example/hyprland.conf