aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIkalco <[email protected]>2024-07-27 10:02:02 -0500
committerGitHub <[email protected]>2024-07-27 16:02:02 +0100
commitec672b1ab95e341a0dcb6679592ae4e5eea9b1cf (patch)
tree40541dc24365a55b4bc36bf2ecf9c6bf4767c708 /CMakeLists.txt
parent963816b9a6524a99a6716fa1aa30b2c4f369d2f0 (diff)
downloadHyprland-ec672b1ab95e341a0dcb6679592ae4e5eea9b1cf.tar.gz
Hyprland-ec672b1ab95e341a0dcb6679592ae4e5eea9b1cf.zip
protocols: move screencopy and toplevel export to hyprwayland-scanner (#7065)
* move screencopy and toplevel export to hyprwayland-scanner * oops
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bd4e0d5..8a27d81b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -288,17 +288,16 @@ endfunction()
target_link_libraries(Hyprland OpenGL::EGL OpenGL::GL Threads::Threads
libudis86 uuid)
-protocol("protocols/wlr-screencopy-unstable-v1.xml"
- "wlr-screencopy-unstable-v1" true)
protocol(
"subprojects/hyprland-protocols/protocols/hyprland-global-shortcuts-v1.xml"
"hyprland-global-shortcuts-v1" true)
+
protocol(
- "subprojects/hyprland-protocols/protocols/hyprland-toplevel-export-v1.xml"
- "hyprland-toplevel-export-v1" true)
-protocol("unstable/text-input/text-input-unstable-v1.xml"
- "text-input-unstable-v1" false)
+ "unstable/text-input/text-input-unstable-v1.xml"
+ "text-input-unstable-v1" false)
+protocolnew("subprojects/hyprland-protocols/protocols" "hyprland-toplevel-export-v1" true)
+protocolnew("protocols" "wlr-screencopy-unstable-v1" true)
protocolnew("protocols" "wlr-gamma-control-unstable-v1" true)
protocolnew("protocols" "wlr-foreign-toplevel-management-unstable-v1" true)
protocolnew("protocols" "wlr-output-power-management-unstable-v1" true)