aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-07-18 21:27:03 +0300
committerMihai Fufezan <[email protected]>2024-07-21 19:24:17 +0300
commit928d1dd38a6e4a791d4a4374a4a3bf02311adbb2 (patch)
tree28ea69ce96fb5e9a8fb2ebfdf0742b042cc36661 /CMakeLists.txt
parentfaa157e1626fb56b5f01ac0597518cc41bf1c40b (diff)
downloadHyprland-928d1dd38a6e4a791d4a4374a4a3bf02311adbb2.tar.gz
Hyprland-928d1dd38a6e4a791d4a4374a4a3bf02311adbb2.zip
CMake, Meson, Nix: replace props.json with VERSION
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e951b874..b65d361e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,8 +4,8 @@ include(CheckIncludeFile)
include(GNUInstallDirs)
# Get version
-file(READ ${CMAKE_CURRENT_SOURCE_DIR}/props.json PROPS)
-string(JSON VER GET ${PROPS} version)
+file(READ "${CMAKE_SOURCE_DIR}/VERSION" VER_RAW)
+string(STRIP ${VER_RAW} VER)
project(Hyprland
DESCRIPTION "A Modern C++ Wayland Compositor"