aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvaxerski <[email protected]>2024-09-19 11:39:54 +0100
committervaxerski <[email protected]>2024-09-19 11:40:00 +0100
commit92df6b0dce1b81b130c2b0e46d206c8c3dbb2971 (patch)
treed0f4939addce5f793fdb655046eb373e72fffac2 /CMakeLists.txt
parent71963972bff15acccd9abd0dfd3e70504609b7cc (diff)
downloadHyprland-92df6b0dce1b81b130c2b0e46d206c8c3dbb2971.tar.gz
Hyprland-92df6b0dce1b81b130c2b0e46d206c8c3dbb2971.zip
version: log build aquamarine version
log the built against aq version, might be useful when it's mismatched to identify the problem
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6fdf98db..b6ac8efc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,11 +91,14 @@ find_package(OpenGL REQUIRED COMPONENTS ${GLES_VERSION})
pkg_check_modules(hyprctl_deps REQUIRED IMPORTED_TARGET hyprutils>=0.2.1)
+pkg_check_modules(aquamarine_dep REQUIRED IMPORTED_TARGET aquamarine)
+
+add_compile_definitions(AQUAMARINE_VERSION="${aquamarine_dep_VERSION}")
+
pkg_check_modules(
deps
REQUIRED
IMPORTED_TARGET
- aquamarine
xkbcommon
uuid
wayland-server
@@ -220,7 +223,7 @@ target_precompile_headers(Hyprland PRIVATE
message(STATUS "Setting link libraries")
-target_link_libraries(Hyprland rt PkgConfig::deps)
+target_link_libraries(Hyprland rt PkgConfig::aquamarine_dep PkgConfig::deps)
# used by `make installheaders`, to ensure the headers are generated
add_custom_target(generate-protocol-headers)